We’re experiencing display issues.
Incident Report for Wealthsimple
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 09:47 EDT
Identified
We're currently experiencing a display issue. We're working on a fix and everything will be back to normal shortly.
Posted Apr 15, 2024 - 09:45 EDT
This incident affected: Wealthsimple Trade (Account), Wealthsimple Invest (Account), Wealthsimple Cash (Account), and Wealthsimple Crypto (Account).