Account Opening Service Degradation
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved as of 11:24 p.m EST.

Thank you for your patience!
Posted Mar 19, 2020 - 23:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 19, 2020 - 21:02 EDT
Identified
We are currently experiencing issues with one of our back-office platforms that is preventing users from creating new accounts.

Our team is investigating. Thank you for your patience.
Posted Mar 19, 2020 - 21:00 EDT
This incident affected: Apps (iOS app, Android App) and Account Opening.