Prepaid Mastercard Issues | Problèmes de carte Mastercard prépayée

Incident Report for Wealthsimple

Resolved

This has been resolved.

Ce problème a été résolu.
Posted Apr 01, 2026 - 20:06 EDT

Investigating

Some prepaid Mastercard transactions are currently being declined due to a technical delay. A fix has been implemented and we're monitoring the results.
Posted Apr 01, 2026 - 19:12 EDT
This incident affected: Cards and Payments (Physical Card).