Trading Platform Degradation
Incident Report for Wealthsimple Trade
Resolved
The incident was resolved as of 4:06 pm EST on July 9, 2019. All normal trading activities can be resumed as quotes are displaying correctly. Thank you for your patience.
Posted 2 months ago. Jul 09, 2019 - 16:16 EDT
Investigating
We are currently experiencing issues with order submissions for securities that have previously undergone corporate actions. If you hold one of these securities this may cause your account balance to temporarily display inaccurately. Our team is investigating - thank you for your patience.
Posted 2 months ago. Jul 09, 2019 - 10:21 EDT
This incident affected: Market Data (Quotes, Security Search), Trading (Order execution, Order submission), and Account Values.